0
Under review
gabrielguzman 5 months ago in Voki Presenter • updated by Gil Sideman 5 months ago 1

I am trying to use my paid subscription to Presenter and when I try to login, I get the same error message and a warning that the site is not trusted. I am using Firefox (latest update), and it worked one day, then the next doesn't. Could you tell me if there is something that can be done?

Under review

Gabriel -

sorry about the inconvenience.

please send a note to support and we'll be able to better review and advise knowing your account details.

Thanx!